Read timeouts after computer sleeps while Docker process is running

After my computer wakes from sleep, the Docker process that runs my local FaunaDB instance starts having issues. Particularly, it becomes unresponsive and I get “Read timed out” errors when trying to interact with it via the official JS client.

Is this a known issue? Has it been looked into? Thanks!

FaunaDB version: 2.11.0-c95355b

I’ve tried restarting the Docker process, but the issue persists.

The only “solution” I’ve found is to erase all of my data and start over.

This is not a known issue and thanks for reporting it. I tried to reproduce this on Mac by sleeping for about 15 minutes and could not. Which OS and how long was you computer asleep (hours, days) ? Next time it happens, can you please zip the log, data folder and send it to jay@fauna.com. Meanwhile, I will continue to try to repro this. Also, looks like you are using little old version. May be time to pull latest ?

1 Like

I pulled the latest version (20.04.01-44e33bb) and I’m still seeing the issue.

I just sent an email to you with the data/log folders.

Which OS and how long was you computer asleep (hours, days) ?

macOS 10.14.5

The issue seems to appear overnight.

Thanks for looking into this!

Hi Alec, Thanks for the data/log folders. Looks like upgrading Fauna by skipping intermediate versions and using existing volumes causes issues and timeouts. I was able to repro that part but could not reproduce the timeout due to computer sleeping for longer.
Can you please do us a favor by starting a latest version of Fauna container with fresh data and confirm if you still see the issue ?

Well, I finally reproduced it 19 days after upgrading and clearing all data.

Sending the data and log folders to you now…

Hey @Jay-Fauna, can you confirm if the data/logs I sent have been received, and whether they’ve helped you pinpoint the issue? Thanks!

Hi Alec, apologize for late response. I did go through the logs and there is no indication of any timeouts(response code: 503) on the queries for the timeframe(July29th) you mentioned. All the 503 seems to be from 24th. Did you see this issue again ?

cat query.log | jq -c 'select(.response.code==503)' | jq .ts
"2020-07-24T23:46:06.062Z"
"2020-07-24T23:46:06.086Z"
"2020-07-24T23:46:06.086Z"
"2020-07-24T23:46:06.085Z"
"2020-07-24T23:46:06.086Z"

Okay, I’ve sent another .zip whose query.log contains a 503 response. Check your email, thanks!

Did anything ever come of this?

Did you see the issue again ? There was nothing solid I could make from the last set of logs.

Damn, that’s puzzling. I just saw the issue again with Fauna 2.12.2. I’ll try upgrading to 3.0.0 soon. Are the breaking changes for v3 listed somewhere?

@aleclarson it indeed is puzzling. You can find the release notes for 3.0.0 at here. Changes are on the API.