Fwitter - problem with CORS policy


I tried to follow the great example you published here:

I am able to do everything (setup, populate, npm start) but when I try to log in with a user, I have this error.

What can I do?

Thanks! (And your examples and tutorials are awesome by the way! :nerd_face:)

1 Like

Hey @Nshiab, first of all, thanks for the kind words. The repository might be broken in the meantime due to some security update. I can take a look shortly to see whether I can reproduce the issue.

What version of chrome are you using?

Thanks for the answer. :slight_smile:

It’s the version 89.0.4389.82.

I can’t reproduce it, even with the last chrome version. It seems as if Fauna upgrades response header to https://localhost:3000 instead of http://localhost:3000 but I could be wrong since it’s been a while that I dealt with CORS issues.

This has something to do with mixed content (http local and https for Fauna) but I find it strange that it doesn’t happen on my side. You could always try to run it from https locally if you just want to get it working. I’ll try to find an answer though.

Actually, your answer pointed me in the right direction! I remembered having installed an extension to force https. This one => HTTPS Everywhere | Electronic Frontier Foundation

I stopped it and now it works.

I am sorry I bothered you for something like that… But maybe you could add a sentence just saying “In case of a problem when trying to log in, disable your extensions and try again” ?

Thanks for the help and for your great work. :slight_smile:

1 Like