Instance not found when searching documents using index

Hey there,
I have an index let’s say it’s “booksByAuthor” where I pass the ref of the author and the index should be returning an array of refs of the books written by this author. The problems occurs when I pass a ref of a specific author (the document exists and is in the correct shape), whenever I tried to search the document using the UI, it’d tell me “Instance not found” and “Document not found”.
However, if I run the query in Fauna Shell
Paginate(Match(Index('BooksByAuthor'), Ref(Collection("authors"), "theRealIdOfAuthor")), {size: 99999})
I’d get the document without any problems
Any help or advice would be appreciated!

Hi @TryCatch - welcome to the Fauna forums!

Did you choose FQL from the dropdown when searching by Ref?

For example, see the following screenshot using the demo data, showing all products for the Alice customer by Ref. The obscured text is:

Ref(Collection("customers"), "101")

Hello @rob, thanks for the quick reply, yes I did choose FQL, and this problem only occurs with a specific ref, when I’m using a different ref, it shows the result correctly :confused:

Hi @TryCatch. It looks like we need to dig a little deeper with you. Can you please create a ticket at using the email associated with your Fauna account?


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.