Fauna shell add-endpoint gives error: ECONNREFUSED


I installed fauna shell and tried to add a new endpoint and when I run the command it gives this error: Error: Error: connect ECONNREFUSED

I also tried on port 8433 by mistake.

I have windows and I have run this command in cmd and PowerShell also.

I am not sure if this error has to do with fauna shell or some windows configuration but I would appreciate if you have any idea how to debug or fix this.


Hi @ClaudiaGiv!

Did you explicitly set the local instance of Fauna Dev to run on port 8433?

If not, I believe that’s a typo - it runs on port 8443 by default.

Hi @rob
Yes it run on 8433 last time by mistake but at first I tried with 8443 and it gives the same error.

Hrm - I can reproduce this in one of two ways:

  • Fauna Dev isn’t running
  • Fauna Dev is running on another port

add-endpoint requires the container to be running in order to add the endpoint but does not require the secret to be valid or correct.

Since you’ve checked the port, can you double-check that the container started successfully with docker ps ?

If so, there are two other things to check:

  • Was port 8443 mapped with docker run -p 8443:8443 when you started the container?
  • Do you have a firewall running blocking connections on port 8443?

I’m not familiar enough with Windows to know if there are other things you could look for.

1 Like

Thanks @rob, the problem was with docker.
I use docker for windows and it crashed (stopped unexpectedly) so the docker container was not running and that’s way fauna dev was not working, like you said.
After I restarted docker and started the container it worked. :tada:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.